So I purchased a Phantom 4 back in August.  I had both an Galaxy S5 phone and a Google Nexus 7 tablet to fly my drone with.

I had three good month of flying with the Phantom and then they came out with the Mavic and a new firmware update.

And boom no more video from the DJI app. from my drone and the S4 stopped working all together.

Now three months later I have spent $500 on tablets.  And numbers calls to DJI telling me my devices are not supported.

I have flown my drone at my shop where I work with several of the guys phones to find an answer.   The only device I have

found to work is my friends I-phone 6.  And if your like me that's a kick in the pants because the android if suppost to work?????

Any update on this? Just wondered if you got it working.

iPad mini 4 that was the fix!  Not any Android device I tried worked with my drone.

I used several of my co-workers phones to find the answer.  I couldn't believe it.

I bought two new Android tablets and sold them.  Then a friend at work let use his I-phone 6.

So three new tablets and three months later i got my drone working.  Finally!